Back to overview
Degraded

Overall latencies are higher for dashboard and API service

Mar 25 at 11:22pm IST
Affected services
Dashboard
API Service

Resolved
Mar 26 at 12:31am IST

Latency is back to normal now

Updated
Mar 25 at 11:29pm IST

Update: This is originating from cloudflare. We are observing, latency is still high.

Created
Mar 25 at 11:22pm IST

This seems to be originating from the cloud provider. We are in touch with them.